URI - BEECROWD - BEE 1045 - Triangle Types Solution in C,C++,Python | URI - BEECROWD - BEE 1045

URI - BEECROWD - BEE Online Judge Solution  1045 | Triangle Types - URI - BEECROWD - BEE 1045 Solution in C,C++,Python

Read 3 double numbers (A, B and C) representing the sides of a triangle and arrange them in decreasing order, so that the side A is the biggest of the three sides. Next, determine the type of triangle that they can make, based on the following cases always writing an appropriate message:

  • if A ≥ B + C, write the message: NAO FORMA TRIANGULO
  • if A2 = B2 + C2, write the message: TRIANGULO RETANGULO
  • if A2 > B2 + C2, write the message: TRIANGULO OBTUSANGULO
  • if A2 < B2 + C2, write the message: TRIANGULO ACUTANGULO
  • if the three sides are the same size, write the message: TRIANGULO EQUILATERO
  • if only two sides are the same and the third one is different, write the message: TRIANGULO ISOSCELES

Input

The input contains three double numbers, A (0 < A) , B (0 < B) and C (0 < C).

Output

Print all the classifications of the triangle presented in the input.

Input SamplesOutput Samples

7.0 5.0 7.0

TRIANGULO ACUTANGULO
TRIANGULO ISOSCELES

6.0 6.0 10.0

TRIANGULO OBTUSANGULO
TRIANGULO ISOSCELES

6.0 6.0 6.0

TRIANGULO ACUTANGULO
TRIANGULO EQUILATERO

5.0 7.0 2.0

NAO FORMA TRIANGULO

6.0 8.0 10.0

TRIANGULO RETANGULO

URI Online Judge Solution  1045 | Triangle Types - URI 1045 Solution in C,C++,Python:

                                        Demonstration:

What is a triangle?

A simple closed curve or a polygon formed by three line-segments (sides) is called a triangle.

Rules of a Triangle:

The sum of the lengths of any 2 sides of a triangle must be greater than the third side.

Rules of triangle

Types of triangles based on sides

Equilateral triangle: A triangle having all the three sides of equal length is an equilateral triangle.

equilateral triangle

Since all sides are equal, all angles are equal too.

Isosceles triangle: A triangle having two sides of equal length is an Isosceles triangle.

isosceles triangle

The two angles opposite to the equal sides are equal.

Scalene triangle: A triangle having three sides of different lengths is called a scalene triangle.

scalene triangle


N.B: Don't copy paste the code as same. Just try to understand it and try yourself. It would be better for you.


  URI Problem 1045 Solution in C :   

  URI Online Judge 1045 Solve  in C :                                                                             
#include <stdio.h>

int main(){
    double a,b,c;

    scanf("%lf %lf %lf", &a, &b, &c);

    if(a >= (b+c) || b >= (a+c) || c >= (a+b))
         printf("NAO FORMA TRIANGULO\n");
    else if(a*a == (b*b + c*c) || b*b == (a*a + c*c) || c*c == (a*a + b*b))
           printf("TRIANGULO RETANGULO\n");
    else if(a*a > (b*b + c*c) || b*b > (a*a + c*c) || c*c > (a*a + b*b))
           printf("TRIANGULO OBTUSANGULO\n");
    else if(a*a < (b*b + c*c) || b*b < (a*a + c*c) || c*c < (a*a + b*b))
           printf("TRIANGULO ACUTANGULO\n");
    if(a == b && a == c)
            printf("TRIANGULO EQUILATERO\n");
    if((a == b && a != c)  || (a == c && a != b) || (b == c && b != a))
            printf("TRIANGULO ISOSCELES\n");

 return 0;
    
}

0 Response to URI - BEECROWD - BEE 1045 - Triangle Types Solution in C,C++,Python | URI - BEECROWD - BEE 1045

Post a Comment