URI - BEECROWD - BEE 1061 - Event Time Solution in C,C++,Python | URI - BEECROWD - BEE

URI - BEECROWD - BEE 1061 - Event Time Solution in C,C++,Python | URI - BEECROWD - BEE Online Judge Solution 1061 - Event Time

Peter is organizing an event in his University. The event will be in April month, beginning and finishing within April month. The problem is: Peter wants to calculate the event duration in seconds, knowing obviously the begin and the end time of the event.

You know that the event can take from few seconds to some days, so, you must help Peter to compute the total time corresponding to duration of the event.

Input

The first line of the input contains information about the beginning day of the event in the format: “Dia xx”. The next line contains the start time of the event in the format presented in the sample input. Follow 2 input lines with same format, corresponding to the end of the event.

Output

Your program must print the following output, one information by line, considering that if any information is null for example, the number 0 must be printed in place of W, X, Y or Z:

W dia(s)
X hora(s)
Y minuto(s)
Z segundo(s)


Obs: Consider that the event of the test case have the minimum duration of one minute. “dia” means day, “hora” means hour, “minuto” means minute and “Segundo” means second in Portuguese.

Input SampleOutput Sample

Dia 5
08 : 12 : 23
Dia 9
06 : 13 : 23

3 dia(s)
22 hora(s)
1 minuto(s)
0 segundo(s)

URI 1061 - Event Time Solution in C,C++,Python | URI Online Judge Solution 1061 - Event Time :

                                        Demonstration:

We need to find the difference between two given date times in Days, Hours, and Minutes and Seconds.
First we need to taking all of the inputs. Then we will subtract the start time from the end time. Now we have the actual day,hours,minutes,seconds. Finally, print the result.

N.B: Don't copy paste the code as same. Just try to understand it and try yourself. It would be better for you.


  URI Problem 1061 Solution in C :   

  URI Online Judge 1061 Solve  in C :                                                                             
#include <stdio.h>
int main(){
 int h, hh, hr,m,mm,d,dm,s,ss;

 scanf("Dia %d",&d);
 scanf("%d : %d : %d\n",&h,&m,&s);
 scanf("Dia %d",&dm);
 scanf("%d : %d : %d",&hh,&mm,&ss);

s = ss - s;
m = mm - m;
h = hh - h;
d = dm - d;

if(s<0){
	s+=60;
	m--;
}

if(m<0){
	m+=60;
	h--;
}

if(h<0){
	h+=24;
	d--;
}

    printf("%d dia(s)\n", d);
    printf("%d hora(s)\n", h);
    printf("%d minuto(s)\n", m);
    printf("%d segundo(s)\n", s);


 return 0;
}

0 Response to URI - BEECROWD - BEE 1061 - Event Time Solution in C,C++,Python | URI - BEECROWD - BEE

Post a Comment