URI / BEE CROWD 1094 - Experiments Solution in C,C++,Python | URI - BEECROWD - BEE 1094 Solution in C,C++,Python

URI / BEE CROWD 1094 - Experiments Solution in C,C++,Python | URI - BEECROWD - BEE 1094 Solution in C,C++,Python

                                                                                            beecrowd | 1094

Experiments

Adapted by Neilor Tonin, URI  Brazil

                                                                                             Timelimit: 1


Maria has just started as graduate student in a medical school and she's needing your help to organize a laboratory experiment which she is responsible about. She wants to know, at the end of the year, how many animals were used in this laboratory and the percentage of each type of animal is used at all.

This laboratory uses in particular three types of animals: frogs, rats and rabbits. To obtain this information, it knows exactly the number of experiments that were performed, the type and quantity of each animal is used in each experiment.

Input

The first line of input contains an integer N indicating the number of test cases that follows. Each test case contains an integer Amount (1 ≤ Amount ≤ 15) which represents the amount of animal used and a character Type ('C', 'R' or 'S'), indicating the type of animal:
CCoelho (rabbit in portuguese)
RRato (rat  in portuguese)
SSapo (frog in portuguese)

Output

Print the total of animals used, the total of each type of animal and the percentual of each one in relation of the total of animals used. The percentual must be printed with 2 digits after the decimal point.

Input SampleOutput Sample

10
10 C
6 R
15 S
5 C
14 R
9 C
6 R
8 S
5 C
14 R

Total: 92 cobaias
Total de coelhos: 29
Total de ratos: 40
Total de sapos: 23
Percentual de coelhos: 31.52 %
Percentual de ratos: 43.48 %
Percentual de sapos: 25.00 %

URI / BEE CROWD 1094 - Experiments Solution in C,C++,Python | URI - BEECROWD - BEE 1094 Solution in C,C++,Python

                                                       Demonstration:

This program takes n number of elements from the user and stores it . Then check the conditions for each test case contains an integer Amount (1 ≤ Amount ≤ 15) which represents the amount of animal used and a character Type ('C', 'R' or 'S').

Then calculating the total amount of animals used ( C+R+S ) and percentage of individual animals . Finally print the result.

N.B: Don't copy paste the code as same. Just try to understand it and try yourself.

  URI / BEE 1094 Solution in C :   

  URI / BEECROWD Online Judge 1094 Solve  in C :                                          

#include<stdio.h>
int main()
{
    int i,n,m;char a,b;int sum=0,sum1=0,sum2=0,sum3;
    double t,l,y;
    b='%';
    scanf("%d",&m);
    for(i=1;i<=m;i++){

        scanf("%d %c",&n,&a);
       if('C'==a){
        sum=sum+n;
       }
       if('R'==a){
        sum1=sum1+n;
       }
       if('S'==a){
        sum2=sum2+n;
       }
    }
    sum3=sum+sum1+sum2;
    t=(sum/(sum3*1.0))*100.00;
    l=(sum1/(sum3*1.0))*100.00;
    y=(sum2/(sum3*1.0))*100.00;
    printf("Total: %d cobaias\n",sum3);
    printf("Total de coelhos: %d\n",sum);
    printf("Total de ratos: %d\n",sum1);
    printf("Total de sapos: %d\n",sum2);
    printf("Percentual de coelhos: %.2lf %c\n",t,b);
    printf("Percentual de ratos: %.2lf %c\n",l,b);
    printf("Percentual de sapos: %.2lf %c\n",y,b);
}

0 Response to URI / BEE CROWD 1094 - Experiments Solution in C,C++,Python | URI - BEECROWD - BEE 1094 Solution in C,C++,Python

Post a Comment