URI - BEECROWD - BEE Solution 1046-Game Time | URI - BEECROWD - BEE 1046 Solution in C,C++,Python

 URI - BEECROWD - BEE Online Judge Solution  1046-Game Time | URI - BEECROWD - BEE 1046 Solution in C,C++,Python

Read the start time and end time of a game, in hours. Then calculate the duration of the game, knowing that the game can begin in a day and finish in another day, with a maximum duration of 24 hours. The message must be printed in portuguese “O JOGO DUROU X HORA(S)” that means “THE GAME LASTED X HOUR(S)”

Input

Two integer numbers representing the start and end time of a game.

Output

Print the duration of the game as in the sample output.

Input SampleOutput Sample

16 2

O JOGO DUROU 10 HORA(S)

0 0

O JOGO DUROU 24 HORA(S)

2 16

O JOGO DUROU 14 HORA(S)

URI Online Judge Solution  1046-Game Time | URI 1046 Solution in C,C++,Python:

                                        Demonstration:

Example of how to calculate total hours worked:

Here we are going to explain how to manually calculate hours worked.  To do this, you will need a start and end time. The goal is to determine an entire duration worked using the recorded hours.  For example, starting @8am and ending @3 pm would result in 7 hours  worked. 

Here's how to determine hours worked:

  1. Convert all times to 24 hour clock (military time)
  2. Next, Subtract the start time from the end time.
  3. Now you have the actual hours worked for the day.
  4. Finally to determined total time duration.
N.B: Don't copy paste the code as same. Just try to understand it and try yourself. It would be better for you.


  URI Problem 1046 Solution in C :   

  URI Online Judge 1046 Solve  in C :                                                                             
#include <stdio.h>
int main()
{
    int a,b;
    scanf ("%d%d", &a, &b);
    if(a==b)
        printf("O JOGO DUROU %d HORA(S)\n",24-a+b);
    else if(a<=b)
        printf ("O JOGO DUROU %d HORA(S)\n",b-a);
    else
        printf("O JOGO DUROU %d HORA(S)\n",24-a+b);
    return 0;
}

2 Responses to URI - BEECROWD - BEE Solution 1046-Game Time | URI - BEECROWD - BEE 1046 Solution in C,C++,Python

  1. Best of luck brother. and hopefully you complete yours rocket project.

    ReplyDelete
  2. Thank you , keep me in your prayer.

    ReplyDelete